Dieser Artikel betrifft die Nintendo Switch

Switch Homebrew-Status

Aus WiiDatabase Wiki
Version vom 27. März 2018, 10:28 Uhr von ICON (Diskussion | Beiträge) (Exploit-Übersicht: 5.0.1)
Wechseln zu:Navigation, Suche

Diese Wiki-Seite zeigt den aktuellen Status der Switch-Exploits.

Was ist möglich?

Begriff Was ist damit möglich?
Userland/Userspace Einfache Homebrew-Anwendungen, bspw. Emulatoren oder ein Homebrew Launcher
Kernel Tiefere Systemzugriffe, dazu zählen eine Custom Firmware, Sigpatches, Titelverwaltung, etc.
TrustZone-Zugriff "Alles": TrustZone verwaltet die Hardware und die Crypto-Engine, damit ist bspw. Zugriff auf die Keyslots möglich

Exploit-Übersicht

Zuletzt aktualisiert: 27. März 2018

Zusätzlich:

  • Coldboot-Exploit von fail0verflow[1]
  • Xecuter-Hardmod[2]
  • "fusée gelée" Coldboot-Exploit[3]
Firmware Userland Kernel TrustZone-Zugriff Öffentlich
5.0.0 - 5.0.1 ? ? ?
3.0.1 - 4.1.0 Ja Nein Ja Nichts, Userland-Exploit "nvhax" ist privat[4] TrustZone-Exploit vorhanden[3]
3.0.0 Ja Nein Ja Userland-Exploit "ROhan" und Homebrew Launcher;[5] TrustZone-Exploit soll mit CFW veröffentlicht werden[4]
2.0.0 - 2.3.0 Ja Nein Ja Nichts, TrustZone-Exploit soll mit CFW veröffentlicht werden[4]
1.0.0 Ja Ja Ja TrustZone-Exploit "jamais vu" (als Write-Up)[6]

CFW-Zeitplan

Zuletzt aktualisiert: 27. März 2018

Die folgenden Firmware-Versionen erhalten zu diesem Zeitpunkt Zugang zur Custom Firmware "Atmosphere"; damit wird auch der jeweilige TrustZone-Exploit öffentlich:
In den jeweiligen Firmware-"Reihen" kann geupdated werden (bspw. von 3.0.1 auf 4.1.0 oder von 2.1.0 auf 3.0.0)

Firmware Wann Notizen
5.0.0 - 5.0.1 Unbekannt Noch ist zu dieser Firmware nichts bekannt.
3.0.1 - 4.1.0 In weit entfernter Zukunft Nach dem Release für 2.0.0 - 3.0.0, das kann sofort oder nach einigen Monaten sein, aber definitiv vor dem Release eines Pokémon-Spiels (SciresM: "3.0.1-4.1.0 will get stuff at a later time, where later could mean immediately or "a few months". In any event everything will be usable before a Pokémon game releases." und "I am preparing for Pokemon to release this year (though who knows whether it will), and Atmosphere will be usable to play Pokemon on versions 1.0.0-4.1.0 via emunand (and use PKHeX etc) -- that is a deadline I refuse to fail to meet")
2.0.0 - 3.0.0 In ferner Zukunft Wenn die CFW weit fortgeschritten ist. (SciresM: "When the CFW is actually well-developed, deja vu will release, usable on 2.0.0-3.0.0 units.")
1.0.0 In naher Zukunft TrustZone-Exploit ist bereits öffentlich als Write-Up. (SciresM: "Once Atmosphere is somewhat usable, I'll make a public PoC to load it using jamais vu on 1.0.0 units.") Eine japanische Kopie von "Puyo Puyo Tetris" wird benötigt, da anders das Web-Applet nicht gestartet werden kann.

Quellen für die Zitate von SciresM: /hbg/

Einzelnachweise